[FAQ Index] | [3.9 -> 4.0] | [4.1 -> 4.2]
Note: Upgrades are only supported from one release to the release immediately following it. Do not skip releases.
It is highly recommended that you read through and fully understand this process before attempting it. If you are doing it on a critical or physically remote machine, it is recommended that you test this process on an identical, local system to verify its success before attempting on a critical or remote computer.
Upgrading is a convenient way to bring your OpenBSD system up to the most recent version. However, the results are not intended to precisely match the results of a wipe-and-reload installation. Old library files in particular are not removed in the upgrade process, as they may be required by older applications that may or may not be upgraded at this time. If you REALLY wish to get rid of all these old files, you are probably better off reinstalling from scratch.
Table of Contents:
Check whether you have made any modifications to your kernel. For example, you might have modified your network device to use a non-default setting using config(8). Note your changes, so you can repeat them for the new 4.1 kernel.
rc.conf:
Unlike previous versions of this process, it is now assumed that
/etc/rc.conf
is not a user-altered file.
If you have made changes to your /etc/rc.conf
file, merge those
changes into /etc/rc.conf.local
.
If you have NO /etc/rc.conf.local
, simply copy your existing
/etc/rc.conf
file to /etc/rc.conf.local
and
delete the last line of the script!
Otherwise, pull your existing rc.conf
into the top of your
existing rc.conf.local
file and remove the last line
before doing the rest of this process.
Special note for ARM users (armish, zaurus): Changes in the ABI requires a slightly different upgrade process if not using standard install kernel. Do not reboot after installing the kernel and before installing the new userland.
One easy way to boot from the install kernel is to place the 4.1 version
of bsd.rd in the root of your boot drive, then instruct the boot loader
to boot using this new bsd.rd file.
On amd64 and i386, you do this by entering "boot bsd.rd
" at the
initial boot>
prompt.
Sometimes, one needs to do an upgrade of a machine when one can't easily use the normal upgrade process. The most common case is when the machine is in a remote location and you don't have easy access to the system console. One can usually do this by carefully following this process:
Note the extra steps for copying over the primary kernel: those are done to ensure that there is always a valid copy of the kernel on the disk that the system can boot from should there be a really badly timed power outage or system crash.export RELEASEPATH=/usr/rel # where you put the files cd ${RELEASEPATH} rm /obsd ; ln /bsd /obsd && cp bsd /nbsd && mv /nbsd /bsd cp bsd.rd bsd.mp /
/etc/firmware
files:
Due to the fact that some uploaded "firmware" files may have been updated,
you may need to update the files in the /etc/firmware
directory.
This will impact users of only a few devices, though all users can use
this step without harm.
To extract the firmware files from base41.tgz
, use the
following as root:
cd / tar -C / -xzpf ${RELEASEPATH}/base41.tgz ./etc/firmware
reboot
!), but often a new userland will NOT
work on the old kernel.
Note: ARM users (armish/zaurus) SHOULD skip this step for this upgrade cycle.
etc41.tgz
and xetc41.tgz
now, because
that will overwrite your current configuration files!
Note: not all file sets will need to be installed for all applications, however if you installed a file set originally, you should certainly upgrade it with the new file set now.export RELEASEPATH=/usr/rel cd ${RELEASEPATH} tar -C / -xzpf base41.tgz tar -C / -xzpf comp41.tgz tar -C / -xzpf game41.tgz tar -C / -xzpf man41.tgz tar -C / -xzpf misc41.tgz tar -C / -xzpf xbase41.tgz tar -C / -xzpf xfont41.tgz tar -C / -xzpf xserv41.tgz tar -C / -xzpf xshare41.tgz
Note: the files in /etc
are handled separately below, so
etc41.tgz
and xetc41.tgz
are NOT unpacked here.
/dev
.
The new
MAKEDEV
file will be copied to /dev by the installation of
base41.tgz
, so you simply need to do the following:
cd /dev ./MAKEDEV all
/etc
as below.
Nov 1 12:47:05 puffy sm-mta[16733]: filesys_update failed: No such file or directory, fs=., avail=-1, blocksize=380204These messages can be safely ignored, or you may wish to halt sendmail(8) during the upgrade process.
/etc
These steps will add both the new users and their corresponding groups. Your environment may allow you to copy/paste those commands.useradd -u88 -g=uid -c"RIP Daemon" -d/var/empty -s/sbin/nologin _ripd useradd -u89 -g=uid -c"HostState Daemon" -d/var/empty -s/sbin/nologin _hoststated
In particular care should be taken with the enc0 interface, as floating states are a potential problem for filtering IPsec traffic: states need to be interface bound, to avoid permitting unencrypted traffic should isakmpd(8) exit. Therefore all rules on the enc0 interface should explicitly set keep state (if-bound).
-g
flag,
it is now the default runtime mode.
The -b
flag (which used to indicate which IP spamd(8) should
listen on) can be used to run spamd in blacklist-only mode.
The new -l
flag is used to indicate which IP spamd should
listen on.
/etc
has been
moved to /etc/mail
.
Move your spamd.conf file into /etc/mail
so that spamd(8) loads
the proper configuration.
hw.sensors.12=it0, Temp 1, 25.00 degC
" you will now see
"hw.sensors.it0.temp0=25.00 degC
".
Update your
sensorsd.conf(5) file to reflect the new names of your sensors.
/etc
file changesetc41.tgz
files to a temporary
location:
Files that can probably be copied fromtar -C /tmp -xzpf ${RELEASEPATH}/etc41.tgz
etc41.tgz
"as is":
Note that it IS possible to locally modify these files, if this has been done, manual merging will be needed. Pay special attention toetc/daily etc/disktab etc/hoststated.conf etc/magic etc/monthly etc/netstart etc/rc etc/rc.conf etc/ripd.conf etc/sasyncd.conf etc/security etc/weekly etc/mail/Makefile etc/mail/localhost.cf etc/mail/sendmail.cf etc/mail/submit.cf etc/mail/spamd.conf etc/mtree/* var/www/conf/bgplg.css var/www/conf/bgplg.foot var/www/conf/bgplg.head var/www/htdocs/bgplg/*
mail/*
if you are using something
other than the default Sendmail(8) configuration.
Here are copy/paste lines for copying these files, assuming you unpacked
etc41.tgz
in the above recommended place:
cd /tmp/etc cp daily disktab hoststated.conf magic monthly netstart rc rc.conf ripd.conf sasyncd.conf security weekly /etc cp mtree/* /etc/mtree/ cp mail/Makefile mail/localhost.cf mail/submit.cf /etc/mail cp mail/sendmail.cf /etc/mail # Careful on this one!! cp mail/spamd.conf /etc/mail # OR... mv /etc/spamd.conf /etc/mail cd /tmp/var/www cp conf/bgplg.css conf/bgplg.foot conf/bgplg.head /var/www/conf mkdir /var/www/htdocs/bgplg cp htdocs/bgplg/* /var/www/htdocs/bgplg/
Files that must be manually merged, respecting any local changes made to them, if they were modified from the default, otherwise, just copy them over, too:
The changes to these files are in this patch file. You can attempt to use this by executing the following as root:etc/changelist etc/ftpusers etc/login.conf etc/newsyslog.conf etc/services etc/sysctl.conf etc/mail/aliases var/cron/tabs/root
This will test the patch to see how well it will apply to YOUR system, to actually apply it, leave off the "cd / patch -C -p0 < upgrade41.patch
-C
" option.
Note that it is likely that if you have customized files or not kept
them closely updated, or are upgrading from a snapshot of 3.9, they may
not accept the patch cleanly.
In those cases, you will need to manually apply the changes.
Please test this process before relying on it for a machine you can not
easily get to.
The following files have had changes which should be looked at, but it is unlikely they should be directly copied or merged (i.e., if you are using pf.conf, look at the suggested change of strategy, and decide if it is appropriate for your use).
Finally, use newaliases(8) to update the aliases database and mtree(8) to create any new directories:etc/hostapd.conf etc/pf.conf etc/sensorsd.conf
newaliases mtree -qdef /etc/mtree/4.4BSD.dist -p / -u
If you followed the instructions for the upgrade process without install kernel, you have already completed this step. However, if you used the install kernel, and if you had a modified kernel in 4.0, it is likely you will need to modify the stock kernel of 4.1. This can be as simple as modifying a specific device using config(8), or it can involve a recompilation if the option you need is not included in the GENERIC kernel. Please consult FAQ 5 - Building the system from source before considering to recompile your kernel.
The following package is known to have significant upgrade issues that will impact a large number of users. The fact that a package is not on this list doesn't mean it will have a trivial upgrade. You must do some homework on the applications YOU use.
pkg_add -u
.
For instance, to update all your packages, make sure PKG_PATH
is
pointing to the 4.1 packages directory on your CD or nearest FTP mirror,
and use something like
where the# pkg_add -ui -F update -F updatedepends
-u
indicates update mode, and -i
specifies
interactive mode, so pkg_add will prompt you for input when it encounters
some ambiguity. Read the
pkg_add(1)
manual page and the package management
chapter of the FAQ for more information.
[FAQ Index] | [3.9 -> 4.0] | [4.1 -> 4.2]