[FAQ Index] | [4.7 -> 4.8] | [4.9 -> 5.0]
Note: Upgrades are only supported from one release to the release immediately following it. Do not skip releases.
It is highly recommended that you read through and fully understand this process before attempting it. If you are doing it on a critical or physically remote machine, it is recommended that you test this process on an identical, local system to verify its success before attempting on a critical or remote computer.
Upgrading is a convenient way to bring your OpenBSD system up to the most recent version. However, the results are not intended to precisely match the results of a wipe-and-reload installation. Old library files in particular are not removed in the upgrade process, as they may be required by older applications that may or may not be upgraded at this time. If you REALLY wish to get rid of all these old files, you are probably better off reinstalling from scratch.
Table of Contents:
with the simpler form:nwid myssid wpapsk `wpa-psk myssid wpapassword`
nwid myssid wpakey wpapassword
Afterwards, complete the upgrade by following the final steps as detailed below.
One easy way to boot from the install kernel is to place the 4.9 version
of bsd.rd in the root of your boot drive, then instruct the boot loader
to boot using this new bsd.rd file.
On amd64 and i386, you do this by entering "boot bsd.rd
" at the
initial boot>
prompt.
Sometimes, one needs to do an upgrade of a machine when one can't easily use the normal upgrade process. The most common case is when the machine is in a remote location and you don't have easy access to the system console. One can usually do this by carefully following this process:
(note: you will get a harmless error message if your platform doesn't have a bsd.mp):export RELEASEPATH=/usr/rel # where you put the files cd ${RELEASEPATH} rm /obsd ; ln /bsd /obsd && cp bsd /nbsd && mv /nbsd /bsd cp bsd.rd bsd.mp /
export RELEASEPATH=/usr/rel # where you put the files cd ${RELEASEPATH} rm /obsd ; ln /bsd /obsd && cp bsd.mp /nbsd && mv /nbsd /bsd cp bsd.rd / cp bsd /bsd.sp
Note the extra steps for copying over the primary kernel: those are done to ensure that there is always a valid copy of the kernel on the disk that the system can boot from should there be a really badly timed power outage or system crash.
cp /sbin/reboot /sbin/oreboot
etc49.tgz
and xetc49.tgz
now, because
that will overwrite your current configuration files!
Note that we are installing base49.tgz LAST, because it will include a new
tar(1)
utility, which may or may not run on the old kernel.
We reboot immediately, as the system is probably barely runnable now.
Not all file sets will need to be installed for all applications, however if you installed a file set originally, you should certainly upgrade it with the new file set now.tar -C / -xzphf xserv49.tgz tar -C / -xzphf xfont49.tgz tar -C / -xzphf xshare49.tgz tar -C / -xzphf xbase49.tgz tar -C / -xzphf game49.tgz tar -C / -xzphf comp49.tgz tar -C / -xzphf man49.tgz tar -C / -xzphf base49.tgz # Install last! /sbin/oreboot
Again, the files in /etc
are handled separately below, so
etc49.tgz
and xetc49.tgz
are NOT unpacked here.
/dev
.
The new
MAKEDEV
file was copied to /dev by the installation of
base49.tgz
, so you simply need to do the following:
cd /dev ./MAKEDEV all
etc49.tgz
which have not been dealt with so far.
There are two processes we provide for you -- manually copying over some
files and patching others, or using the
sysmerge(8)
process.
Who may wish to NOT use sysmerge(8):
With recent improvements in sysmerge, we hope that relatively few
people have reason not to use sysmerge(8)!
However, people with a large quantity of similar machines to upgrade
may find the "patchfile" process faster, and perhaps the basis of
a customized upgrade script.
Using sysmerge(8) for the first time:
If you have a system that's been upgraded in the past via the patchfile
process you will probably find the FIRST time you upgrade by sysmerge,
you have a LOT of manual file changes to make.
This is because the patch file process only attempted to achieve
functional compatibility on the upgraded system, and did not respect
the version control information sysmerge(8) uses to identify "unchanged"
files.
Rest assured, later runs of sysmerge will be far less painful, and often
completely effortless.
The sysmerge(8) utility will compare the files that are actually on your system with those that would be installed in a fresh install, and assist you in merging the changes into your system. Note that unlike the patch file, there are no assumptions made about what is actually on your system, so you can use sysmerge(8) to move between more arbitrary points in the development process, such as from an earlier 4.8-current to 4.9-release or from one -current to a later one. Sysmerge(8) compares the current files on your system with the files that would have been installed with a new install, and what would have been there from the last run of sysmerge. Usually, it can figure out what to do to update your files, but if it has difficulty, it will give you the option of keeping the old file, installing the new file, or assisting you in the manual merging of the old and new files, using sdiff.
Please read the sysmerge(8) manual page before using it on your system. You are also advised to read the diff(1), sdiff(1) and even review more(1) manual pages before continuing.
Assuming the etc49.tgz
and xetc49.tgz
files exists in
your $RELEASEPATH, run it with:
For the files sysmerge(8) can't resolve on its own, it will show you a unified diff(1), run through your favorite $PAGER (i.e., more(1)) and ask you if you wish to:sysmerge -s $RELEASEPATH/etc49.tgz -x $RELEASEPATH/xetc49.tgz
Use 'd' to delete the temporary ./var/www/htdocs/index.html Use 'i' to install the temporary ./var/www/htdocs/index.html Use 'm' to merge the temporary and installed versions Use 'v' to view the diff results again Default is to leave the temporary file to deal with by hand
If you wish to retain your existing file, delete the temporary file, if you wish to replace your existing file with the new version, install the temporary file. If you wish to merge the two together, choosing 'm' will put you into sdiff(1), where you can manually merge the file. The default is to come back and deal with the file later, manually.
Sysmerge(8) saves all your replaced files into a temporary directory,
similar to /var/tmp/sysmerge.24959/backups
, so if you accidentally
clobber something that was probably not such a good idea, you have a chance
to recover it. Note that
daily(8)
cleans old files from this directory.
No new users and groups need to be created for 4.9.
You will want to extract the etc49.tgz
files to a temporary
location:
Files that can probably be copied fromexport RELEASEPATH=/usr/rel tar -C /tmp -xzphf ${RELEASEPATH}/etc49.tgz
etc49.tgz
"as is":
Note that it IS possible to locally modify these files; if this has been done, do NOT simply copy over those files, and consider using the sysmerge(8) process instead. Here are copy/paste lines for copying these files, assuming you unpackedetc/daily etc/disktab etc/man.conf etc/monthly etc/netstart etc/nsd.conf etc/pf.os etc/rc etc/rc.conf etc/weekly
etc49.tgz
in the above recommended place:
cd /tmp/etc cp daily disktab man.conf monthly netstart nsd.conf pf.os rc rc.conf weekly /etc
These files likely have local changes, but should be updated for 4.9. IF you have not altered these files, you can copy over the new version, otherwise the changes should be merged with your files:
The changes to these files are in this patch file. Please test this process before relying on it for a machine you can not easily get to. You can attempt to use this by executing the following as root:etc/changelist etc/rc.local etc/rc.shutdown etc/services etc/ssh/sshd_config etc/sysctl.conf var/www/conf/mime.types
This will test the patch to see how well it will apply to YOUR system; to actually apply it, leave off the "cd / patch -C -p0 < upgrade49.patch
-C
" option.
Note that it is likely that if you have customized files or not kept
them closely updated, or are upgrading from a snapshot of 4.8, they may
not accept the patch cleanly.
Make sure all file changes are attempted; patch(1) may quit prematurely
if it gets too confused in one file, which may happen if your machine
was originally installed from a snapshot or otherwise has some interim
changes.
The last file to be changed here should be var/www/conf/mime.types
.
Deleting the file sections that fail from the patch file may permit the
rest to be applied.
You will need to manually apply the changes that are skipped.
The following files have had changes which should be looked at, but it is unlikely they should be directly copied or merged (i.e., if you are using pf.conf, look at the suggested change of strategy, and decide if it is appropriate for your use).
etc/bgpd.conf etc/ldap/core.schema
Finally, use newaliases(8) to update the aliases database, mtree(8) create any new directories:
newaliases mtree -qdef /etc/mtree/4.4BSD.dist -p / -u
cd /usr/bin rm addftinfo afmtodit eqn grodvi groff grog grohtml grolj4 grops grotty \ hpftodit indxbib lkbib lookbib neqn nroff pfbtops pic psbb refer sectok soelim \ tbl tfmtodit troff cd /usr/share rm -r dict/eign groff_font tmac doc/psd doc/smm doc/usd groff cd /usr/share/man/cat1 rm addftinfo.0 afmtodit.0 eqn.0 grodvi.0 groff.0 grog.0 grohtml.0 grolj4.0 \ grops.0 grotty.0 hpftodit.0 indxbib.0 lkbib.0 lookbib.0 neqn.0 nroff.0 \ pfbtops.0 pic.0 psbb.0 refer.0 sectok.0 soelim.0 tbl.0 tfmtodit.0 troff.0 cd ../cat3 rm sectok.0 sectok_apdu.0 sectok_cardpresent.0 sectok_close.0 \ sectok_dump_reply.0 sectok_fdump_reply.0 sectok_fmt_fid.0 \ sectok_friendly_open.0 sectok_get_input.0 sectok_get_ins.0 \ sectok_get_sw.0 sectok_open.0 sectok_parse_atr.0 \ sectok_parse_fname.0 sectok_parse_input.0 sectok_print_sw.0 \ sectok_reset.0 sectok_selectfile.0 sectok_swOK.0 sectok_xopen.0 cd ../cat5 rm groff_font.0 groff_out.0 cd ../cat7 rm groff_char.0 groff_me.0 groff_mm.0 groff_mmse.0 groff_ms.0 groff_msafer.0 \ me.0 mm.0 ms.0 rm /usr/bin/vgrind rm /usr/share/man/cat1/vgrind.0 rm /usr/share/man/cat5/vgrindefs.0 rm /usr/share/misc/vgrindefs /usr/share/misc/vgrindefs.db rm /usr/bin/colcrt /usr/share/man/cat1/colcrt.0 rm /usr/bin/checknr /usr/share/man/cat1/checknr.0 rm /sbin/wpa-psk rm /usr/X11R6/bin/xft-config /usr/X11R6/man/man1/xft-config.1 \ /usr/X11R6/include/X11/extensions/lbxbuf.h \ /usr/X11R6/include/X11/extensions/lbxbufstr.h \ /usr/X11R6/include/X11/extensions/lbximage.h
If you followed the instructions for the upgrade process without install kernel, you have already completed this step. However, if you used the install kernel, and if you had a modified kernel in 4.8, it is likely you will need to modify the stock kernel of 4.9. This can be as simple as modifying a specific device using config(8), or it can involve a recompilation if the option you need is not included in the GENERIC kernel. Please consult FAQ 5 - Building the system from source before considering to recompile your kernel.
The following packages are known to have significant upgrade issues that will impact a large number of users. The fact that a package is not on this list doesn't mean it will have a trivial upgrade. You must do some homework on the applications YOU use.
The package tools support in-place updating using pkg_add -u
.
For instance, to update all your packages, make sure PKG_PATH
is
pointing to the 4.9 packages directory on your CD or nearest FTP mirror,
and use something like
where thepkg_add -ui
-u
indicates update mode, and -i
specifies
interactive mode, so pkg_add will prompt you for input when it encounters
some ambiguity. Read the
pkg_add(1)
manual page and the package management
chapter of the FAQ for more information.
[FAQ Index] | [4.7 -> 4.8] | [4.9 -> 5.0]